You are currently not logged in.  Logon or register to access more features. Vision-Riders.com is a FREE service provided by Victory Riders Network.

Search:




High Beams are stuck on
Jump to page : 1
Now viewing page 1 [25 messages per page]
View previous thread :: View next thread
   Discussion -> Vision Tech Q&AMessage format
 
EGA44
Posted 2018-05-05 2:21 PM (#192526)
Subject: High Beams are stuck on


Cruiser

Posts: 52
Gotha, FL
Riding the other day and noticed the high beam indicator light was flickering. Then it just went to solid and so when I stopped for lunch I looked and my high beams are on and the switch is no longer working and won't turn off the high beam. Any ideas as to what the problem might be? I have the switch block cube apart and can see the switch but that's as far as I have gotten. I thought I would spray it with a contact cleaner and see if that helps but beyond that I am a novice with electrical issues.
Top of the page Bottom of the page
rdbudd
Posted 2018-05-06 11:39 AM (#192528 - in reply to #192526)
Subject: RE: High Beams are stuck on


Visionary

Posts: 1581
Jasper, MO
The moving parts may be stuck from dirt and water getting in. The contact cleaner is a good idea, and I would follow up with WD40 to displace any moisture and lubricate the contacts and rocker assembly. Good luck.

Ronnie
Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [25 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

Copyright © 2007-2018 Victory Riders Network™