You are currently not logged in.  Logon or register to access more features. Vision-Riders.com is a FREE service provided by Victory Riders Network.

Search:




Clutch / Oil pressure issue
Jump to page : 1
Now viewing page 1 [25 messages per page]
View previous thread :: View next thread
   Discussion -> Vision Tech Q&AMessage format
 
Bohica
Posted 2017-06-27 6:06 PM (#192040)
Subject: Clutch / Oil pressure issue


Puddle Jumper

Posts: 5
I had something weird happen after a 350 mile ride. When I pull the clutch lever, the oil pressure light comes on. I can barely apply pressure and it will come on, and as soon as I release, it goes off. I can "flick" the lever, and the light will flicker on and off at the same rate. I checked the oil level, and its fine. Bike has 1300 miles on it since last service. Weird, I know. Any ideas? Thanks.
Top of the page Bottom of the page
jdr00ejr
Posted 2017-06-30 8:59 AM (#192047 - in reply to #192040)
Subject: RE: Clutch / Oil pressure issue


Cruiser

Posts: 70
Indianapolis, IN United States
I had the EXACT same problem after I was working on the bike. Totally freaked me out. Finally realized what happened. Check to see if the Oil Pressure Wire is binding in the Clutch Slave Cylinder. For me - I had moved the slave cylinder checking on something and apparently when I put it back the oil pressure wire got caught. It was basically pinching the wire every time the clutch lever was even slightly applied. I was able to move wire back out of the way and the problem instantly went away.
Top of the page Bottom of the page
Bohica
Posted 2017-07-01 10:08 AM (#192048 - in reply to #192040)
Subject: Re: Clutch / Oil pressure issue


Puddle Jumper

Posts: 5
Thanks for the reply. I had my tires replaced yesterday and while it was on the lift, I traced the wire coming from the OPS and found exactly that. I had just flushed the clutch fluid and the wire was stuck behind the "head" of the slave cylinder! Thanks again.
Top of the page Bottom of the page
jdr00ejr
Posted 2017-07-03 6:58 AM (#192051 - in reply to #192040)
Subject: Re: Clutch / Oil pressure issue


Cruiser

Posts: 70
Indianapolis, IN United States
Happy to help! Glad you traced it down.
Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [25 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

Copyright © 2007-2018 Victory Riders Network™